New 5D MIII underexposing - what am I doing wrong

Started Mar 31, 2012 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPrevious
Flat view
billorg Senior Member • Posts: 1,184
New 5D MIII underexposing - what am I doing wrong

Hi, first I want to thank everyone for helping me and others on the forum. Your advice has always been invaluable and you have helped make me a better photographer over the years!

I have a question about exposure..

I did a few shots with my new 5D MIII tonight while the light was still good and noticed the camera w/35mm f1.4L is underexposing by 2/3 of a stop in .jpg - to my eye at least. My 7D was always about 1/3 under, my 20D may have been 2/3 also if I remember correctly.

I also normally set my Canons to center weighted average metering - I literally have never had to change it for the type of shooting I do. I set the 5D today to this and the exposures were all over the place and I felt myself changing it from that to spot metering over and over. My 7D seemed to deal with normal ans well as challenging lighting equally well. I had to resort to HDR for many of them. Is this normal? It just feels very off from what I am used to. I am sure I have missed a setting to help this, but I am not sure what it is. Could it be because I turned off Auto Lighting Optimizer? I didn't keep the bad ones so unfortunately I can't post any images.

Does anyone feel their 5d MIII is underexposing at all in .jpg?

Thanks, Bill

 billorg's gear list:billorg's gear list
Sony Alpha NEX-5N Canon EOS 5D Mark III Sony SLT-A99 Canon EOS 6D Canon EOS 70D +13 more
Canon EOS 20D Canon EOS 5D Canon EOS 7D
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
tmr
BAK
BAK
BAK
tko
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow