Sigma 150 Macro OS ~~ AF Issue??

Started Feb 27, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
wihakowi
Regular MemberPosts: 213Gear list
Like?
Sigma 150 Macro OS ~~ AF Issue??
Feb 27, 2012

Just got this lens and am not sure whether I have a bum lens or just have to live with its limitations as a macro.

One request in advance - please no Sigma bashing, "You shoulda got the Canon 100" responses. My reasons for the Sigma were very clear:
~ Great reviews.
~ Extra working distance the 150mm gets me.
~ Tripod ring.
~ Ability to accept Canon converters which I already have.

Tried shooting with 7D and T3i, with and without 1.4 mkII converter, single point, AI Servo, with and without tripod.

1) The AF seems to be very hit and miss as to when it actually operates at all. Sometimes it works as expected, reasonably fast and accurate. Much of the time though, it will not AF at all and I have to shut down power to the body and/or switch the lens from AF to MF back to AF and/or move the focus ring near the focus point before the AF actually actuates. It feels as if the AF simply turns itself off at random times and has to be "re-set" in order to work. It is more frequent when using the Canon 1.4 converter but happens as well with the bare lens.
Any thoughts?

2) The second issue may or may not be related to #1. No matter what I do, the lens will not actuate AF at all when closer than about 2 feet to my subject. I have tried all 3 distance pre-sets, Af > MF > AF (like above) and total re-sets without success. I know that at "true" macro distances the AF is normally slower but what I have is a lens that simply doesn't try! It is like the challenge detailed above except that AF will never work - no matter what I do.
Is this normal?

I really want this to work out for me but without AF at short distances I am sunk. It is heavy enough that I need two hands to hold it and the body and my old eyes need the AF - my shaky old hands could use the OS as well but I understand I'm not to expect too much in that arena up close. My hope was to also be able to use it with my Canon 2x mk III converter but I don't even dare try it with the erratic operation bare and with the 1.4!

I have also not tried Live View since it normally does not work well with what and how I shoot - butterflies & dragonflies.

I just got the lens yesterday and was NOT impressed with Amazon packaging. The Sigma box was snug in the Amazon box with 5 of the 6 sides hard against each other. I emailed them as soon as I opened their box to let them know so they are "warned" to the possibility that it got jostled pretty good in shipping.
Think that could have loosened up something or caused a problem?

Thanks in advance for your help,
Steve

 wihakowi's gear list:wihakowi's gear list
Canon EOS 7D Canon EOS 600D Canon EF 50mm f/1.4 USM Canon EF 100mm f/2.8L Macro IS USM Canon EF 70-200mm f/2.8L IS II USM +8 more
Canon EOS 600D (EOS Rebel T3i / EOS Kiss X5) Canon EOS 7D
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow