S95 Batteries behaving weird

Started Feb 21, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
fotopaul
New MemberPosts: 7
Like?
S95 Batteries behaving weird
Feb 21, 2012

I have some trouble with my 2 original canon battery-packs (NB-6L) and my S95. When the battery goes down to about 50% battery life and sometimes even before that, turning the camera on won't work with a short note of "change battery" displayed, this being the same for both battery packs. Now if the battery would be empty that would ofc all be fine and well, yet the battery isn't nearly empty. Most of the times opening up the battery compartment and trying to switch on the power just the instant after closing it again seems to fix the issue of the camera complaining about not enough power in the battery and it actually turns on fine and can be used for as long as I don't turn it off.

The camera obviously isn't that old just yet, same as the batteries, and while I don't use the camera on a daily basis I don't think I 'under-' or even 'overused' the camera to warrant this pretty annoying behaviour. I can't imagine the batteries already being old or used-up and I never charge them up before they're actually empty (going by numbers of pictures shot or when I simply can't get the camera to turn on again at all), so I can't find any reasons in my treatment of the camera which could be the cause for all of this.

Did anyone else have this issue? Could it be the sign of a faulty camera or are for some reason both my battery packs the victims of an early demise? Does anyone know a fix for the issue or simply know where it all came from?

Any help would be appreciated.
-fotopaul

Canon PowerShot S95
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow