Yognuo 468 & 565 incompatible with Canon 550D

Started Feb 16, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Mark my words
Forum MemberPosts: 77
Like?
Yognuo 468 & 565 incompatible with Canon 550D
Feb 16, 2012

I have a problem with Yongnuo 468 & 565EX on a Canon 550D.

Both work ok in hotshoe. All functions showing and adjustable on flashgun and on camera.
When I remove the flashgun the on-board Canon Flash ceases to work.

Going into Built-in Flash Functions the camera says the menu cannot be displayed external flash is attached (which it isn't) Going into External Flash Function setting it says this menu cannot be displayed. Incompatible flash or flash's power is turned off. It says the same for External C.fn settings and Clear ext. flash C.Fn Set.

I've tried turning it on and off and even removing the battery but it still thinks the Yongnuo is attached and if I do attach it it will work fine. This has happened several times but if I leave it for an hour or so the on-board flash gets working again for no apparent reason untill I re-attach the Yongnuo.

Anyone have any idea what is going wrong.

-- hide signature --

Mark

Canon EOS 550D (EOS Rebel T2i / EOS Kiss X4)
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow