My brand new K-5 just died!

Started Feb 5, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Kamgal
Junior MemberPosts: 33Gear list
Like?
My brand new K-5 just died!
Feb 5, 2012

I got my Pentax K-5 on Wednesday. I took less than twenty pictures in the next two days just to check focus which was fine with the Tamron 17-50.

Today I took it on a birdwalk with the DA 55-300 set for continuous shooting hi and AF continuous. Before I got out of the car, I tried one shot, and the camera searched for focus, didn't focus, then started making a whining noise for several seconds. It would not turn off or respond to any button. Within a minute it went black and would turn back on.

When I got home, I put in another battery from my K-7, fully charged as was the K-5 battery. I took several pictures and then on the next picture the whine noise came back, much shorter, and the camera went black. I tried the battery in the K-7 and it would not turn on.

Now I charged both batteries which only took about half an hour. The K-5 was originally charged with its new charger and the second time with the charger from the K-7.

I put the 55-300 on the K-7 and I was able to shoot without any problem.

So then I put the charged K-5 battery back in the K-5, put on the 55-300 and I took several pictures and even did the hi continuous shooting successfully.

I turned it off to take out the SD card to load the pictures on my computer. Before the SD could come it (it has been tight and a little hard to get out), the camera turned back on by itself, but only with the status screen, but not all information showing and the LCD panel was also on, but not all the information showing, and the camera was set to off, I tried switching it back on and off, but the screens stayed on for awhile. Finally the back LCD went off, but the top LCD panel was no longer lighter, but with partial part of several letters or numbers showing.

The images I did get in the three day were all fine, sharp focus and ISO 6400 looked great on an interior evening living room shot.

I will return the camera, but wanted to share this and also ask if anyone has any ideas what happened. When I first changed the lens, I thought that maybe I hadn't mounted it correctly (though that had never happened to me before with my K20D or K-7), but just when I though I was home free, the K-5 sputtered to a sad end in three days!

And yes, I am one of the fortunate people that got the wonderful price from Samy's, when they honored their mistake. I don't see this as bad omen, in fact this is the first time I have ever had a problem with three cameras and four Pentax lenses, a Tamron lens, and a few Takumars and Adaptall 2 lenses. Just guess my time was up!

Pentax K20D Pentax K-5 Pentax K-7
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow