Unusually high amount of hot pixels in my images

Started Jan 21, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
a hit of meth
Forum MemberPosts: 54
Like?
Unusually high amount of hot pixels in my images
Jan 21, 2012

I bought an Olympus E-pl3 the other day and I noticed one or two hot pixels appearing in the same areas between 200-320 iso, sometimes a few more which is sometihing I can live with. However beyond 320 and especially between 500-800 they seem to appear in unusually high numbers scattered around the frame. I counted 10 in shot easily noticale when magnified. I exchanged it and I got the same thing with the replacement.

They don't appear in every image but they do appear in a lot of them, maybe a third of my pictures have them. I know hot pixels can't be avoided but this seems like an unusually high amount and it gets annoying when I have a shot and someone has white dots in their hair or jacket or whatever. I know there is software available for this but I can't spend all my time going on photoshop removing dead pixels from my pics.

This is my first micro 4/3 system so I don't know if this is normal for this type of camera or this model. Any input would be appreciated.

Btw, can anyone tell me where I can upload full size images for me to put up an example, I tried photobucket and flickr but the site resized them.

Olympus PEN E-PL3
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow