Nikon SB-800 Problem - won't charge/eats batteries

Started Jan 16, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
garyb1985
Forum MemberPosts: 67
Like?
Nikon SB-800 Problem - won't charge/eats batteries
Jan 16, 2012

Hi,

Weird problem this. My SB800 and I have lived in bliss for quite some time and its seen a fair amount of action but recently its not been behaving right. I shoot in nightclubs and previously could go for most of a night on one set of AAs (maybe 200+ pics with flash)

Recently I've been lucky to get maybe 20 shots (CLS - TTL I'd guess 1/4 power max per shot) before the flash starts firing underpowered. It will inform me of this with the -3EV symbol on the display and continue to be underpowered on subsequent shots. The strange thing is that if I then manually pop the flash with the red button it will go back to behaving normally, giving me correct exposures, for maybe another 5 or 10 shots before doing the same thing and dropping the power off.

Has anyone ever experienced this- I cant find any similar problems with searching- the only thing I can think of is some kind of capacitor problem but i'm nowhere near qualified enough to diagnose it!

-- hide signature --

Light is Light, its what you do with it that counts

http://gbmultimedia.co.uk

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow