SX40 - sluggish&unstable AF (in comparison to FZ150!)

Started Dec 18, 2011 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
longtalker
Forum MemberPosts: 79
Like?
SX40 - sluggish&unstable AF (in comparison to FZ150!)
Dec 18, 2011

Hello fellow SX40 owners,

I was wondering if other people are having problems with the AF on this otherwise excellent camera. The AF on mine is quite slow and unstable especially in low-light and at telephoto, but also, at times, even under 'ideal' conditions (wide lens, sunny etc).

I was wondering if someone found a workaround for this, or whether anyone knows how likely it is that Canon will release a firmware to fix this issue (seems like a software rather than a hardware issue to me, as the AF keeps trying to find a better focus even though the image is already perfectly crisp).

I bought both the SX40 and the Panasonic FZ150, as I simply could not make up my mind just based on specs & reviews However, even after testing them for 2 days, I still find it very hard to make a decision. I tend to prefer the Canon, however if I don't somehow get round this AF problem, I'll have to go with the Panasonic, as it is simply too annoying to have a camera that constantly struggles to find/maintain focus.

Many thanks for any replies!

Panasonic Lumix DMC-FZ150
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow