help with quantum turbo battery

Started Oct 4, 2011 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Mark van Dam
Regular MemberPosts: 179
Like?
help with quantum turbo battery
Oct 4, 2011

I have a Quantum Turbo battery that's giving me some trouble. My other Turbo batteries all have a metal prong that plugs into a coupling in the bottom of the leather case. I am definitely not an electronics expert, but my guess is that this is a ground, as these batteries do not function properly, until the battery and electronics are seated in the leather housing.

This battery, however, does not have the metal prong (see red arrow in photos below). I have tried changing the cell (twice, even swapping known working cells from other units). The rest of the panel lights up properly, but the high voltage indicator light (lightning bolt icon) will not light when I plug in flash units. I've tried swapping out cords, using flash units that definitely work in my other units, but to no avail. Plugging in a Turbo Battery sometime gets me one flash, before the "Check Turbo" message starts beeping.

Does anyone know if I'm missing something obvious here. Could it have something to do with the grounding of this unit?

Any help is greatly appreciated.

-- hide signature --

--Mark van Dam

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow