I am so angry with Fuji right now, I want the world to know...

Started Aug 23, 2011 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
dotyman
Junior MemberPosts: 41
Like?
I am so angry with Fuji right now, I want the world to know...
Aug 23, 2011

OK, so I bought the X100, used it for a week and the well-known lens exposure problems raised their ugly head on me. In aperture priority mode, anything but F/2.0 produced increasingly over-exposed/blown highlights. Tested and tested for user error, but it's an AUTO-exposure mode! No luck . Shooting the same scene in AE mode produced wildly varying exposures. Problems with the aperture blades, right?

Called Fuji tech support and the tech "had no idea that there was such an issue." He suggested that I check several, obvious, settings on the camera (dumb customers, you know how it is...). Still no luck.

I explained that numerous other buyers have posted on various forums about the issue, and he still played ignorant to the problem. I asked for someone that was more familiar with the camera, and he back-pedaled a bit and explained that if there "was" such an issue, I need to send my camera in so the techs can repair it. He also explained that they would be "familiar" with any such problems.

I sent my camera to New Jersey, with an explanation that it seriously over-exposed, at a cost of $36 for three-day delivery. They acknowledged receipt a day late and overnight shipped it back to me, apparently repaired.

Got it today. The repair receipt says that they inspected and "cleaned" it. That's it.

The camera is a week old, and it needs cleaning? Needless to say, it has the exact same problem that it had went I sent it in. Wasted postage cost for a camera that I am beginning to think is an absolute debacle.

I honestly am beginning to have doubts about Fujifilm's competance at making cameras. Sure, we can overlook the many flaws, like so many do of Microsoft products, but that simply does not sit well with me. It's too expensive.

At least my $2000 X1 can get an accurate exposure, and the damn histogram works in manual mode.

Anyway, sorry to hop on the soap box about this, but I am EXTREMELY disappointed in the X100. So much promise, such incompetent execution. I will never buy another Fuji product, and neither will anyone else, if I can help it.

Thanks for listening.

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow