F56AM acting up

Started Jul 18, 2011 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPrevious
Flat view
bmadau Contributing Member • Posts: 577
F56AM acting up

It seems that my 3yr old F56AM flash is starting to have some issues. I just noticed this last week it has been randomly over exposing shots when using the bounce flash. I cleaned the hot shoe contacts but that didn't help any.

It's pretty random but I have been able to find one use case that has been pretty consistent in reproducing the problem. I shoot landscape for a bit, while it is working fine, but then turn the camera to portrait orientation, and the flash starts doing full power bursts. I turn it back to landscape and it still keeps firing full power bursts. I turn the flash off and on a gain, and it's shooting ok again for a bit. It doesn't appear to have this problem when shooting with direct flash. I even tried putting the flash into manual mode while this was going in, and setting the power to 1/32, and it still fired full power bursts. This was just my 5 min diagnosis. I did not spent forever identifying exactly when and why it does this.

And to add to that, the wireless function no longer functions. I've started shopping around for an F58 but that's still a good chunk of change.

Any suggestions on how to fix this? Is it worth while to pursue getting my flash repaired?

Thanks,
BM

ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow