Disappointing street shoot with X100 - help!

Started Jul 2, 2011 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Goldenmom
Forum MemberPosts: 61
Like?
Disappointing street shoot with X100 - help!
Jul 2, 2011

I normally shoot with a D700+20mm but today for my farmer's market shoot I brought only my X100. I've been shooting with it around the house and thought I had a good handle on usage, but I found the camera really disappointing today. My main complaint is that I'd go to take a picture and the camera was in some sleep mode and therefore wouldn't take a shot. Turning the camera on/off didn't always help. Midway through the shoot I turned off all the sleep settings and still I swear I'd go to take a picture and nothing would happen. (And yes, I have the latest firmware.)

What am I missing?

In the times the camera was on, I found it rather slow to take the shot. I shoot a lot of candids with dogs with their owners and only one came out decent. The others ended up a second or too late and the dogs would be out of position and the shot ruined. It wasn't like the shots were blurry or out of focus--in fact they often looked very crisp--but the timing just wasn't there.

I took 46 shots and got a single keeper, which was a posed shot and the very first one of the day. I was with a girlfriend and we were shopping/eating so it wasn't going to come home with a ton of photos, but I expected to keep more than one.

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow