K-5 and third-party (only?) external flash problems

Started Jun 7, 2011 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
PolarHki
Regular MemberPosts: 331
Like?
K-5 and third-party (only?) external flash problems
Jun 7, 2011

I own a Soligor DG-420 Z external flash, which worked fine on my Pentax K10D and also on the K20D. Now I upgraded to the Pentax K-5, and when I put the Soligor DG-420 Z flash on the camera and switch the camera on, immediately the flash will release a quick series of (not very intensive) flashes, then recharge, then release another series of (not very intensive) flashes, and so on - and all that without that any button on the camera was pressed, or any shot was triggered.

Apparently, also other users got the same problem, see for example here:

http://www.youtube.com/watch?v=XD_gZZTLSG0&feature=related

And yes, I have the latest 1.03 firmware for the K-5 installed.

My questions are:

  • Is there any way to solve these problems, and to make third-party flashes like the Soligor DG-420 Z work correctly with the Pentax K-5?

  • Are these problems limited to third-party flashes, or have people also observed similar issues with Pentax's own flashes (e.g., AF-360FGZ or AF-540FGZ)?

Thanks beforehand for any info / help!

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow