Going back to Firefox 3.6.15 if you installed FF 4.x

Started Mar 21, 2011 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Jim Cockfield
Forum ProPosts: 14,677
Like?
Going back to Firefox 3.6.15 if you installed FF 4.x
Mar 21, 2011

If you've accidentally installed Firefox 4 (RCs or betas), and you've realized the that newer 4.x versions are a POS (and I don't mean Point of Sale), just download Firefox 3.6.15 again, install it, and you should be back in good shape again.

Here's a link to 3.6.15

http://www.mozilla.com/products/download.html?product=firefox-3.6.15&os=win&lang=en-US

Personally, I suggest avoiding the newer 4.x versions, unless you have no other choice.

-- hide signature --
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow