Total frustration !

Started Mar 16, 2011 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Mannypr
Veteran MemberPosts: 3,363Gear list
Like?
Total frustration !
Mar 16, 2011

Well guys...I just received the lens back again today and would anyone here believe THE LENS CAME BACK EXACTLY AS IT LEFT. With no autofocusing working. This is the third time I have sent them my lens to be fixed and nothing !. I am totally frustrated at this. I have seven other lens in my collection . Even another tamron , a 28-75mm F2.8 and all of them are working perfectly with my camera so I have ruled out camera fault.

The first time I sent Tamron the lens was because of the underexposure issue and at the same time I told them to check the autofocusing system which once in a full moon would refuse to autofocus briefly. The first time it came back the underexposure issue was fixed but now the autofocusing system would work intermitently . Called them , sent it back and the second time it came back the autofocusing system just did not work at all.

Today when I received the lens for a third time it came back exactly as it was sent. Nothing ....nada ...zip...no autofocusing at all. Tomorrow I'll be calling them again and will tell them that I don't want the lens any more and want a new one and if that one came back bad I will send it back for a refund from tamron as this going and coming is at best totally and completely unaceptable .

The lens is a 70-300mm VC . I like the lens so much as to have patiently waited for them to fix it but now I'm calling it quits and want a new one at that.

 Mannypr's gear list:Mannypr's gear list
Canon PowerShot A640 Nikon D90 Nikon D7000 Nikon AF-S DX Nikkor 18-55mm f/3.5-5.6G II Nikon AF-S DX Nikkor 18-105mm f/3.5-5.6G ED VR +8 more
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow