AF-A not working on my D90. Totally stumped.

Started Jan 31, 2011 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Zenyatta
New MemberPosts: 3
Like?
AF-A not working on my D90. Totally stumped.
Jan 31, 2011

Hi everyone, this is my first post. I have a little problem.

I was taking pictures in AUTO mode with AF-A yesterday and all of a sudden the viewfinder went dark and I couldn't take any more pictures. (I'm fairly new to this camera and still learning about it.)

When I try to half-press the shutter, the AF just shuffles around a bit and nothing happens. It won't focus lock and won't open the shutter.

The white dot blinks repeatedly in the viewfinder telling me that the AF can't lock.. I have tried going outside into the sunlight, inside into darkness and trying to focus on close and far away objects but nothing. I can take pictures in manual focus mode or continuous AF mode but no other mode. So AF-A and AF-S don't allow me to take pictures but AF-C does.

I have tried a hard reset, unmounting the lens, using a different lens, charging the battery... I have checked for damage on the body's lens mount... I am still stumped. Please help, I am about to go on an OS holiday and it will be heartbreaking not to have a camera working. It is a couple of years old but it has never been dropped, knocked around or otherwise mistreated.

oh and the lens is a nikkor kit lens 18-105mm. I get the same problem with the 50mm lens.

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow