s95 excitement and disappointment: quality issues

Started Jan 31, 2011 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
scholar
New MemberPosts: 10
Like?
s95 excitement and disappointment: quality issues
Jan 31, 2011

Hi! This it my first post here, although I've been keeping an eye on this forum for quite a while...

Well, the story has begun in December when I decided to upgrade my IXUS 870 to S95. The first shots with S95 were just like "wow!" to me - clear, sharp, perfect colours, etc. straight out of the camera. But there was a nasty hot pixel, quite clearly visible on the images, so I asked the seller (Amazon UK) for a replacement... The 2nd S95 I got was just a disappointment - "soft" images, with the upper part being consistently more blurry - obviously, lens issues. Bad luck, I thought (I actually wished I had kept the 1st camera)... Anyway, this camera went back to Amazon, too (for a refund).

So, I have now bought the 3rd S95 (again from Amazon). This one seems to be "okay" image-wise (still, I have a feeling that the 1st one was superior). What bothers me is that just after a couple of first shots it showed me "Lens error. Camera will restart automatically" message. After restarting, it works... but this messages has appeared another couple of times - I was playing with the camera in low-light conditions, and it was quite hard to focus... I have also checked the information stored in firmware (via vers.req file, as per CHDK site), it shows on the third screen "E18 Lens Retract Error" (or so) and the time it has happened last time.

The camera seems to be working fine at the moment, but I am worried about that E18 error message... Shall I return again, or keep? I would appreciate your feedback...

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow