PocketWizard Mini & Flex Issues

Started Jan 16, 2011 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Unorthodox
New MemberPosts: 15
Like?
PocketWizard Mini & Flex Issues
Jan 16, 2011

Probably not the right place on the forums for such a thread (not sure where is), but here it goes...

I picked the PocketWizard MiniTT1 and FlexTT5 last month but I've been having a few issues when using the MiniTT1 in basic trigger mode on a non-Nikon camera. Yes, I know that sounds daft complaining that a Nikon trigger has issues when on a non-Nikon camera, but according to the manuals and FAQs :

BASIC TRIGGER MODE: Note that almost all cameras and flashes are compatible with the MiniTT1 and FlexTT5 when the radios are configured for Basic Trigger Mode. Basic Trigger Mode disables ALL power controlling and TTL functions of the radios.

So the problem I'm having is that when the MiniTT1 is taken off camera and unmounted it is unable to trigger an SB-900 mounted on a FlexTT5 (using of course the Test button). The red light will be displayed on both units indicating that they are synced and triggering, but the SB-900 will not flash. Occasionally when switching the flash off and on again I might get 1 or 2 flashes and afterwards, nothing.

What makes it strange is that if the flash linked via sync cable to the FlexTT5 and not mounted on the hotshoe, things work fine. I've tried resetting the flash and triggers but so far no success. Anyone else had any luck?

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow