K-x memory card errors (sorry, SLR newb)

Started Dec 15, 2010 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
RjM76
Forum MemberPosts: 69
Like?
K-x memory card errors (sorry, SLR newb)
Dec 15, 2010

Hi all...

New to the Pentax fold, first time posting in these forums (been here at DPR for awhile, mainly over at the Kodak P&S forums). Been around in these forums for some time, reading and gaining MUCH knowledge and recently bought a K-x, and I have an issue.

The first few days everything seemed ok, but the other day I noticed that, going thru looking at some of the recent pics on the LCD, I get an "image cannot be displayed" error. I know the shots took because I always check the LCD after taking a shot, but I guess somewhere the file failed to correctly write to the memory card (a brand new Transcend 8GB Class 10 card). I thought it was odd, but tried to keep shooting and got a message saying my card was full, but according to the counter still had well over 800 shots available.

Anyway, later that night, emptied the card, formatted several times, both in Windows and in camera, updated the K-x firmware, and formatted again. So last night, started shooting, and again ran into the same error, saying image could not be displayed. Does this sound like a card issue? I'm hoping it's not the camera, seeing as how both card and camera are new. I tried doing a search but didn't get any results.

Sorry for the longwinded post

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow