Card error, battery light, and clicking noises: HS-10

Started Dec 9, 2010 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
TD912
New MemberPosts: 1
Like?
Card error, battery light, and clicking noises: HS-10
Dec 9, 2010

Hi guys, recently upgraded from my trusty old S5200 to an HS-10. So far everything has been mostly working, except I am getting randomly getting a "CARD ERROR". It's hard to reproduce the problem, but when it does happen, it stays reproducible for a while.

I went outside, turned the camera on, rotated the zoom ring, the camera appeared to reboot and then displayed "CARD ERROR". I repeated it a few more times and the same thing happened each time. I formatted the card using the camera. It still happened. I had a 4GB Kingston Class 6 in there at the time.

Puzzled, I went back inside and put in a different card, a 4GB Sandisk Ultra Class 4. I turned the camera on inside, and turned the zoom ring. Nothing happened. Alright, maybe the card was causing something funky to happen? I walk back outside, turn on the camera, and mess around with the zoom some more. No more problems.

I then point the lens towards the ground. Not pressing any buttons. The camera instantly restarts with the "Fujifilm" logo and then back to the shooting screen. I raise the camera up, and point it towards the ground again. It spontaneously restarts again!

Basically these problems have been occurring on-and-off, but when they happen, you can easily make it happen again.

I've also noticed the low battery indicator appears rather quickly, although I can continue to take quite a few photos before it completely dies.

Also, sometimes when I turn the power switch to "ON," I hear some clicking noise inside the camera, but nothing appears on the LCD. It sounds like it is trying to startup but can't? If I press the Playback button, the screen will finally turn on and I can switch back to Shooting mode without a problem.Yes, I have set the battery type to "NiMH" in the settings.

Maybe these problems were caused by a set of older NiMH batteries? I'm not sure it ever occurred with plain alkalines. Should I call Fuji, or keep swapping out batteries/cards?

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow