A Possible Source for the Blur Issue, K-x and K-7

Started Nov 6, 2010 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPreviousNextNext unread
Flat view
Forum ProPosts: 32,883
A Possible Source for the Blur Issue, K-x and K-7
Nov 6, 2010

Hey Everyone, I know this isn't scientific but bear with me. I used the K10D and K20D and don't recall a SR blur issue, I also remember they took 0.6 sec to spool, I'll assume the same for the other Pentax cameras of the era (both no issue and spool up time). The K-7 and K-x seemed to have dropped the spool-up time to 0.58 sec, which sounds like a newer more efficient algorithm was implemented, however both the K-x and K-7 had intermittent blur issues at certain shutter speeds.

So far with the tests i've don with the K-5 it appears the SR spool up time is back up to 0.6 sec and nobody yet has found a SR blur issue, yes i know its still early.

could it be that the K-7/K-x generation of SR algorithm had a flaw that was never caught during initial testing?

I was talking with a real Pentax Tech recently about my K-x blur issue, he assured me that the power of the coils holding the sensor could not be overcome by the jolt of the shutter or mirror. I have no reason not to believe him. He has decided he will look for the issue on my K-x but will likely just perform a reset/re-alignment of the SR system on the camera and when i get it back it will be up to me to find out if that fixed the issue.
Mike from Canada

'I like to think so far outside the box that it would require a telephoto lens just to see the box!' ~ 'My Quote :)'


ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow