Ef 50mm f1.4 sharpness issue? Shooting with Xsi/450D

Started Nov 1, 2010 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
stse
Junior MemberPosts: 38
Like?
Ef 50mm f1.4 sharpness issue? Shooting with Xsi/450D
Nov 1, 2010

I shoot primarily with a 450D/ Xsi and use my 50mm f1.4 very often for portrait and candid shots. I am concerned that either my camera body or the EF 50mm f1.4 is not delivering a sharp enough image. I have attached 5 photos to this. Shouldn't images at 1.8 still be pretty sharp for the F1.4 lens?

The images I have attached are as follows:
1) Taken just after I got the lens (no filter)
2) Taken on Oct 30th, 2010 (UV filter)
3) Taken on Oct 31st, 2010 (No filter)

Could you please examine them and let me know if you see something weird or if they aren't sharp? At 100% crops, the don't seems sharp, and that is my concern.

I have hear that the 50mm f1.4 lens has USM and AF motor issues where the motor would get stuck sometimes and not focus. Ths has happened to be a few times. I know this happens to the 85mm f1.8 too, but in that case, you might have to send it into Canon. But for my 50mm, because the lense moves or sticks out when it tries to focus, I have used a UV filter to help twist the lens a little be to the left and right, (screwing motion), and the lens goes back to being able to focus automatically again. Have you had this happen? How do you deal with that? Is my approach safe for the lens?

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow