Motor fault 50-200 SWD, is it common ?

Started Oct 22, 2010 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
sanjaykool
Regular MemberPosts: 437
Like?
Motor fault 50-200 SWD, is it common ?
Oct 22, 2010

As B & H announced price $ 869 price 50-200 SWD lens March this year I bought it rather my niece gifted it.

I was happy with image quality. In May 2010 in two months it had developed focusing problem. No movement on lt some sound was there inside.Initially I tried to write to Olympus USA through web Customer Support. No luck the link to USA customer supports asks me to contact system administration since then. A web site fault unattended.

I took lens to Global Warranty Center in Mumbai. They confirmed it as SWD motor fault. They told that in four weeks it shall be repaired as the motor needs to be ordered from Olympus Singapore Distribution Stock.

After two months also the lens was not repaired. So wrote to Olympus Japan Customer Support Center. Since then I am getting replies that the service center shall contact me. Service centre says no motor has been provided to the service center hence no repairs. Now it is almost four months. I have a planned Himalayan trip now . So I wrote to Japan Customer Support Center. Then Mumbai service center contacted me and initially offered me 70-300 as temporary arrangement till spares are arrived. After refusal from me they offered me my lens with out repair to use manual focus in trip as a stop gap arrangement. I am afraid how can I buy SHG glasses planned with this experience ?

my question is

1) Is it normal to take so much of time ?
2) Is it normal to have SWD motor failure in such a short time ?
3) Does Olympus Japan takes so much time to supply spares ?
4) What could have gone wrong ?

  • Sanjaykool

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow