FL-50R problem... burned TWO

Started Jul 19, 2010 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
patrocal
Regular MemberPosts: 130
Like?
FL-50R problem... burned TWO
Jul 19, 2010

Well a month ago at a Wedding while shooting the FL-50R flash made a loud POP, kinda like popcorn but loud enough that nearby guests heard it. I touched it and it was very very hot. By the time I turned it off it poped again and started smelling. It was dead, it gave a last little wimped flash later when i tried it and that was it. Now I had done probably 20-25 Wedding with that flash so I didn't think much of it, maybe it was just its time.

I bough a brand new one and since then I would often check how hot the Flash gets. Friday, when I decided that it was hot enough i reached to switch it for my other FL-50R and it POPED too. It was 10 days old flash. Both times I was using it with the E-30 and the FP-1 power bracket. The only new component in that equation is the E-30 that I bought in May. Last year I shot probably 30 Weddings with the E-3 + the bracket + the FL-50R with no problem.

So anyone have such experience or an idea what is going on???? Buying $400 flashes every 2-3 weeks will kinda hurt my bottom line hehe.

For the Wedding I shot on Saturday I didn't put batteries in the FL-1 bracket and just used it as an empty bracket since I though that it might overcharge the flash or something.

Any help would be appreciated.

Thanks

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow