My old Minolta XG7- unpacked it, took the front off, need some help

Started Jul 8, 2010 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
OhioBowhunter
Regular MemberPosts: 261
Like?
My old Minolta XG7- unpacked it, took the front off, need some help
Jul 8, 2010

Hello all...this is my first time to the Minolta area. I purchased a Minolta XG-7 back in ~ 79/80 with 2 lens. I packed it away 20 years ago and finally took it out to see what I have. The camera was serviced before I packed it away, and to my surprise, with new batteries, it still works....OR IT DID!

I was cleaning things up... (I will get to other issues later if necessary)...and just could not get the reflector for the viewfinder clean (not the mirror). I figured I would take the front off the camera and see what was up! Not a good idea...because as soon as I took of the metal ring, then the second ring (black plastic one with the contacts for the iso function) a SPRING sprung out of the d*&^* thing. The spring is attached to a post on the black plastic ring, but NOWHERE can I find a termination point for the spring. In the process, I, of course moved things around...etc...but now, after some time have managed to get everything working again, except for where the spring terminates. (I have it just kind of rigged, but it is not right).

IF anyone has a diagram of where this 1" spring terminates and how to attach it, that would be great. I may end up just rigging it to work and call it quits. From what I can determine, the camera really has no value so I don't want to pay for a service manual, I just need to know where the spring goes. I can post a picture of the black ring with the singe end of the spring attached, I just need to know where the other end goes.

Thanks

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow