Problem with video

Started Jul 1, 2010 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
CorneliusSmitty
New MemberPosts: 6
Like?
Problem with video
Jul 1, 2010

Hey guys, something very important, I bought a T2i a month ago and I have never gotten good results from the video. A biggest example I kept doing tests on this red metal fruit basket I have, and each and every single time, when parts of the basket would come into focus from my focus pulls, the metal parts would look very pixelated for some of the seconds they were in focus, and there'd also be what looked like glitching and aliasing jumps where there truly shouldn't be. It was a semi-macro shot, and it was having glitches. I know of the T2i's technology, and I was aware that the camera couldn't handle possibly house roofs or stripped shirts...but fruit and baskets? Hm. Oh yeah, I also get these glitches with every single fricken video I make, no matter what the object or scene is, so yeah...

It doesn't help that overall, every video I take seems very 'indistinct' or hazy somehow. I've seen straight-out-of-the-box videos from the T2i that I have downloaded from helpful users personally, and they all look like you can jump into them because the picture looks real, high-def, and modern. On my camera, I tend to think the videos look like some sort of 2001 standard definition camcorder. Makes it even weirder that if I resize the 1080P videos to 720P, the problems seem to go away for the most part.

Now, I've taken my videos to the local electronic stores, testing the full 1080P on those huge Macs they have, and it's the same result every time, if not worse. The buzzards that work there aren't any help, they all get wow'd by the 'depth of field' before they even subjectively try to agree with me that there are glitches. I haven't had the chance to test other T2i's, but it'd be a big help if someone here could specify wether this sounds 'normal' and that I just need to add a filter or do a bit of editing, or if the T2i is not really supposed to have this issues unless it sees the roof of a house :P.

Please give any insight you can, my 30-day return will be up in just a day or so, so...yeah = . With that, I know Canon or the store will help no matter what, but I may even decide to get a completely different camera if all the T2i's are like this or if I'm just feeling fed up =P.

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow