7D very high ISO in Auto/Programme modes?!

Started May 6, 2010 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
bukowski_jr
New MemberPosts: 3
Like?
7D very high ISO in Auto/Programme modes?!
May 6, 2010

Hi

I acquired the 7D a few months ago, upgrading like many from the 40D which was my first SLR. With the 40D it would keep the ISO down in P mode which i use fairly religiously (tweaking the aperture as i see fit) and using automatic ISO. Particularly in low light or the hour before sunset it worked well. I don't have enough knowledge to use M (Manual). The 40D would give you a long shutter time to indicate when you needed to raise the ISO.

When i use the 7D say half an hour after dawn, instead of going for say ISO 400-800 or something, it leaps up to ISO 3200. It seems to nearly always go for ISO 3200. Even in the hour before sunset it will do it. If it's a heavy cloudy day, it will go for ISO1000 to 2000.

Does anyone know if this is a fault, setting option or just how the 7D works? I really am not happy about it, and thinking of selling the 7D. When you want to quickly take a picture of a wild animal or something as i recently did in Africa, you end up with a grainy image as my 7D has chosen a stupidly high ISO.

Help appreciated!

Cheers

Paul

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow