CS5 under WinXP 64bit -GUI problem Registry Fix and Plug-ins TIP

Started May 1, 2010 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Dan Tong
Contributing MemberPosts: 585Gear list
Like?
CS5 under WinXP 64bit -GUI problem Registry Fix and Plug-ins TIP
May 1, 2010

Good news for Windows XP 64 bit users! PhotoShop CS5 works fine under this excellent, stable, and lean Operating System (OS).

Just as for CS4, you must install both the 64 bit and the 32 bit version. Once again this is so that you continue to have

access to your 32 bit plug-ins. For my setup, everyting installed just fine, but the checkbox for enabling GUI was grayed out.

This is how I solved that problem in order to have full GUI implementation with my older ATI FireGL-3600 video card.

In Photoshop CS5, just as with CS4, (look under the Edit (Pulldown Menu) / Preferences/ Performance) you may find the
Enable OpenGL Drawing

Grayed out for your video card. This is to prevent unstable performance for older video cards. Nevertheless, if you are like me
your video card may be fully usable.

For CS4, Adobe supplied a link to make a change to your Windows Registry to enable this feature. It took me weeks to

get this working, including lots of email messages, posts on forums as well as a call to ATI tech support. None of it worked
until a message from "Slim" on this forum.

Since I could not find any such link for CS5, I examined the AllowOldGPU registry change for CS4 and realized that it was a
very simple entry in the Windows Registry.

So, here I am attempting to explain in detailed steps how to make the change in the Registry.

Under the Run box (Find after clicking on Start in the bottom left hand corner) start the Registry Editor, and type

regedit (then press Enter key to begin editing)

You should see 2 windows, one on the left, another on the right hand side. The left hand window, uses
+ and - signs to open and close the hierarchy.

HKEY_CURRENT_USER
Software
Adobe
Photoshop
11.0
12.0

Highlight 12.0 in Left Window and then you mayl see some of these things in the R. Window

MemoryUsage REG_DWORD 0x00000043 (67)
MemoryUsage64 REG_DWORD 0x0000003e (62)

PaletteFontTypeKey CS4 REG_DWORD 0x00000000 (0) PlugInDirectory REG_SZ C:Program Files\Extra DST Plugins\

You need to add a new DWORD Value. R. Click Mouse to get NEW then choose DWORD Value and write the following

AllowOldGPUS

Then you need to right Click the new line you just created and choose Modify, and then type

1

in the empty Value Data box.

The result should then read

AllowOldGPUS REG_WORD 0x00000001 (1)

That's it. The grayed out item

Enable OpenGL Drawing (Edit (Pulldown Menu) / Preferences/ Performance

Should now be available. I chose Advanced, but you may want to first try the Basic, then Normal before going to Advanced.

I think you need to Exit Photoshop and restart the application before the changes made in Preferences are activated, but I'm not sure.

Finally a very useful TIP:

Create an Additional Plug-Ins folder ( to be set later in Preferences) and COPY (do not MOVE) the 64 bit plug-ins from CS4 Plugins folder into this new folder. Then in both CS4 and CS5 browse to this

folder. Once you've specified your new "External" plug-ins folder, exit Photoshop, then restart. Your plugins will now show up in CS5 without having to

go through the extra work of re-installing all of your plugins from scratch (and setting registration keys etc.).

Hope this is useful for you,

Dan

 Dan Tong's gear list:Dan Tong's gear list
Canon PowerShot G12 Sony RX100 Canon PowerShot S110 Sony RX100 II Canon PowerShot S120 +16 more
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow