Sensor Cleaning Results and Long Term

Started Apr 21, 2010 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPreviousNext
Flat view
James C. Whiteside III
James C. Whiteside III Contributing Member • Posts: 958
Sensor Cleaning Results and Long Term

I have a DL and a K100 that both get used often. I have used the DL much more, and have never had any issues with dust on the sensor, even though the lens get swapped on this camera more often. Though the K100 is a nightmare and seems to get more every week.

Over the last few months I have been using a cheap manual blower, which seems to fix the problem temporarily, but within a few weeks the problem comes back.

Last night I ordered Wet Swabs, Pic-Pads, Eclipse Liquid, and a Rocket Blower in hopes of resolving this issue. But I am currently waiting on arrival. From what I can tell, nothings is hard stuck to the sensor, its all seems to be dust that freely moves when blown.

Theory...

I am under the impression that there is dust in the camera body of my K100 and even though I get the sensor setup temporarily clean, once I start using the camera, the dust starts moving around and causes more issues. Even though my DL is used more, maybe it has cleaner internals, which is why I never seem to have this issue with it.

Question...

Do those that clean and/or blow the sensor often find that the issue repeatedly keeps coming back, even if they don't swap lens?

ForumParentFirstPreviousNext
Flat view
ForumParentFirstPreviousNext
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow