Problem with new 3880 software on Snow Leopard

Started Mar 16, 2010 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
ErichDrazen
New MemberPosts: 14
Like?
Problem with new 3880 software on Snow Leopard
Mar 16, 2010

So I just received my new Epson 3880 and set it up on my macbook pro. The installation seemed to go fine, and I immediately tried printing from photoshop and was very impressed with the results.

HOWEVER, when I tried to open the Epson LFP Remote Panel software or any of the other utilities, they would freeze-up and quit. I tried uninstalling and reinstalling the software, but with no success. I am running OS X 10.6.2. Has anyone else experienced this problem, and if so, were you able to fix it?

Also, I am looking for the Advanced Black & White settings, and can't find find them when trying to print in either Photoshop or Lightroom. In photoshop if I click on Page Setup, the only options I get are:
Settings
Format For
Paper Size Orientation
Scale

Am I missing something? In the manual it says there should be a Print Settings dropbox, but I don't see it anywhere. Could this be related to the other problem I am having?

Appreciate any advise.
Thanks.

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow