5DII and CS3 - NOT Compatable

Started Feb 18, 2010 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPrevious
Flat view
zerostudio
zerostudio Junior Member • Posts: 29
5DII and CS3 - NOT Compatable

Not sure if anyone else ran into this, but its simply NOT compatible.

This is one version back from CS4 and ADOBE isn't interested in making this issue go away.

Why should I have to fork out $$$ for CS4 when my 3 works perfectly fine until now...

Never again will I buy and Adobe product after my conversations I just had with Adobe Philippines (ALL their customer service and tech support location) and Adobe corporate (who could care less) in California.

Seems like the only American company with any dignity at all is Apple - I hope that lasts as there is nothing left in this country - sad.

ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow