Problems with IV FW1.0.6

Started Feb 3, 2010 | Discussions thread
Blake Cook
Senior MemberPosts: 2,207Gear list
Like?
It's a 500 f/4 problem w/ 1D4
In reply to Asposium, Feb 3, 2010

Asposium wrote:

too many of us are reporting problems with our 1D4 for it to all to be user error

especially when many of us are experienced with the canon system

I have not read anything that leads me to believe the 1.0.6 firmware issue affects anything but the 500 f/4 and it doesn't seem to affect that lens when you add a 1.4 or 2.0 TC.

On the other hand I have read all sorts of praise for camera from some very credible photographers.

It is clear that there is some conflict with 500 f/4's that Canon needs to address.

-- hide signature --

Blake in Vancouver
http://flickr.com/photos/28305360@N00/
Panasonic Stuff, Canon Stuff. Mac Stuff & annoying PC & Windows stuff.

 Blake Cook's gear list:Blake Cook's gear list
Canon EOS 5D Canon EOS-1D Mark IV Canon EOS-1D X Canon EF 300mm f/2.8L IS USM Canon EF 16-35mm f/2.8L II USM +5 more
Reply   Reply with quote   Complain
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow