7D Autofocus Problems: A controlled test w/ 40 images, on tripod

Started Oct 26, 2009 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
EricFerguson
New MemberPosts: 16
Like?
7D Autofocus Problems: A controlled test w/ 40 images, on tripod
Oct 26, 2009

Unfortunately it looks like I've got a 7D that has the much-talked about Autofocus problem. I came back from the cottage last week with about 5 good images out of 600, all of the others were just blurry enough at 50% to make the image unusable, but still look fine when fit to the LCD. There was little consistency between back and front focusing, or the amount of error: AF is all over the place.

I've got to say that I've been a little unimpressed by the quality of people's discussion of the 7D AF issue on these boards and elsewhere: it's clear that a lot of people have defective models with a farily serious and frustrating hardware problem, and meanwhile the experienced experts on this site who have the good luck to have a fully functioning camera have been patronizing and unhelpul, with all sorts of offending comments along the lines of "read the f* manual" "learn to use your camera" and even "stop shaking so much when you take pictures"

Not helpful.

The fact is there is a serious hardware issue with a lot of people's cameras which is hard to diagnose, and the fact that your camera works fine doesn't mean that everyone else is stupid or doing something wrong.

Anyway: to help people understand what the issue is before my Camera goes back to Canon tomorrow, I shot a couple dozen frames this afternoon, just popping off shots of a static scene in full manual on a prime lens, while locked down and shooting with a remote release cable. I shot 5 photos at AFmicroadjustment(CfnIII) intervals of 5, from -20 to +20. Then I shot 5 photos focusing manually. The AF was set to "Zone AF" with the leftmost zone selected, just to the left of the big window on the house.

As you can see, AF misses the mark pretty much every time, with the occasional "OK"ish photo but nothing that approaches the precision of the manually focused shot.

The only other body I have on hand at the moment is a 20D, and I can tell you that my 50mm works flawlessy on it, but I didn't include the 20D in this test because its resolution and AF system is so different. I've also done tests with a 17-85IS and a 100-400LIS and the problem persists with the 7D on those lenses, but is absent on the 20D.

The complete set is on flickr at full resolution HERE: http://www.flickr.com/photos/ericferguson/sets/72157622544778671/ The exif is intact, the photos are unedited. Have fun.

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
TomNew
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow