Canon XSI Card Write Protected Issue

Started Sep 24, 2009 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Brandon Brun
New MemberPosts: 2
Like?
Canon XSI Card Write Protected Issue
Sep 24, 2009

Okay, so I have a Canon XSI that I have used to take less then 1,000 shots with and it has worked perfectly the entire time I have owned it. So I had a standard 2gb Sandisk SD card that I was using at first, worked fine. Well I found a good deal on a Sandisk 4gb Ultra II so I purchased it. I put the card in the camera and get an error message that reads, card write protected. This is the first time I have ever received this message and naturally my first thought is to check the lock button on the side of the SD card. Well it isn't switched over so I try again, same message. Well I assume I have a defective card and just plan on exchanging it. Now this is where things get weird, I go ahead and forget about the 4gb and put the 2gb back in and get the same error message. At this point I am pretty confused because it was working right before the 4gb. Well I went ahead and googled the issue and was led to a Flickr forum discussing the same exact issue. They suggested formatting the card, no luck, reinstalling the firmware, no luck, leaving the battery out and replacing, no luck. Finally I decided to call Canon to see if they had any recommendations. They pretty much insinuated that I broke a pin on the inside of the camera when putting the SD card in and claimed it would be $250 to replace. Now I took a flashlight and looked inside the reader and there was no damage whatsoever so I doubt that is the problem. Now I am at a point where I don't know what to do, if anyone has heard of this issue or has any ways of resolving it I am all ears.

Thanks, Brandon

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow