Help - 40D exposure compensation stuck

Started Jul 14, 2009 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
aris
Regular MemberPosts: 249
Like?
Help - 40D exposure compensation stuck
Jul 14, 2009

I get this occasional problem with my 40D - and the only way i've been able to fix it so far is to reset to factory defaults.

Basically my exposure compensation gets stuck at a certain level. I'm really not sure how it gets into this mode, and i'd really like to fix it as it seems to happen at the most inopportune moments!

So here are the symptoms:

The lcd at the top shows -2/3 compensation. Al pictures show this too in the picture info. It doesn't always get stuck at -2/3 - sometimes at other settings both in + and minus compensation levels.

If press the exposure compensation button at the top of the camera, and use the rear-dial to change it (say to 0), after half-pressing the trigger to get back to shooting-mode, the exposure compensation on the LCD still shows -2/3. If I press the exposure compensation button again, the lcd shows the change I made earlier (i.e. 0). Pictures still shoot at -2/3 though

If I press the menu button and check the AEB - it seems to be at -2/3 as the default setting, and any bracketing compensation changes I make there are + 1 the 1/3 stops around the -2/3 setting.

So basically it looks like -2/3 is my default setting which I can't seem to get around.

I'm sure i'm missing something really simple here - but there is nothing in the manual which seems to help.

Can anyone give me some hints?

Thanks,

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow