Memory Card Error

Started Feb 26, 2009 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
ClaudiaInIowa
Junior MemberPosts: 26
Like?
Memory Card Error
Feb 26, 2009

I bought a SX10 in early December and purchased a Promaster 4GB memory card. I had taken about 700 pictures on this card and downloaded them using the camera to my laptop on about 4 occasions. Each time I erased the pictures. I have since heard that I should have "formatted" the card instead of erasing. I then had about 100 pictures on the card and was shooting a flash picture and got a memory card error. Everything had been working fine up to this point. I had changed batteries early in the evening so I would have "fresh power" for taking fireworks on the beach pictures in Jamaica. I had shot several pictures with the newly charged batteries before this happened. I took out this card, put in a new one and everything worked fine. Has anyone else had this happen? And is there any way to recover these photos. I have tried a couple of card readers and they just don't see the card. I have taken the card to our local camera dealer and they have tried today to recover them, but as of now haven't been able to. They are contacting the manufacturer, but I thought I would reach out to this forum and see if anyone had ideas. Thanks for any suggestions-

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow