20D Malfunction Question

Started Feb 7, 2009 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
R1er
Contributing MemberPosts: 573Gear list
Like?
20D Malfunction Question
Feb 7, 2009

Tonight I noticed that when I use my Sunpack 383 with the 20D in aperture priority mode (indoors at night), the flash fires but the shutter speed is one to eight seconds. I currently have my flash sync shutter speed set to 1/250.

It's as if the camera isn't sensing the Sunpack's presence in the accessory shoe. The camera exposes for available light, even though it fires the Sunpack.

When I use the 20D's built-in flash (without the Sunpack), the shutter speed goes to 1/250 like it's supposed to. Two weeks ago, the camera worked perfectly with the Sunpack - that is, the shutter speed went to 1/250.

Also, I set the 20D to Auto sync speed selection and again tried the Sunpack, and had the same result - very long exposures, even though the Sunpack fires. I've tried different modes also - Auto and Program - and had the same result. Also tried all three of my lenses - same result.

I've gone through the manual and can't find anything that would explain this. Is this a malfunction, or do I simply have something set wrong? Thanks in advance for any info.

-- hide signature --

  • Don

 R1er's gear list:R1er's gear list
Canon EOS 7D Canon EOS 70D Canon EF 400mm f/5.6L USM Canon EF-S 10-22mm f/3.5-4.5 USM Canon EF-S 17-55mm f/2.8 IS USM +1 more
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow