D2x problem with AI-s lenses

Started Dec 16, 2008 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
PaoloB
Forum MemberPosts: 76
Like?
D2x problem with AI-s lenses
Dec 16, 2008

I purchased a used D2x two months ago, and since that time I've been working with new lenses without experimenting any type of problem.

In the past days I tried to use some of my older AI-s lenses oin the D2x, but I was able to work correctly with them only at their fastest aperture.

In fact, when I stop down the lens using the manual aperture ring on the lens itself, the camera correctly change the exposure metering, but when I shoot the foto the camera does not succeed in closing the aperture blades. The same happens when I try to push DoFP button, the aperture blades do not close themselves.

Obviously I have inserted the lens data in the D2x menĂ¹. I tried a 135 f:2.8, a 200 f:4 and a 28 f:2.8.

Does anyone experimented this type of problem with a D2x? Is it a hardware fault perhaps?
Thanks in advance for your answers.
Best regards.

Paolo

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow