Please help... having problems with flash (K10D).

Started Jul 16, 2008 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
idhawk
Junior MemberPosts: 32
Like?
Please help... having problems with flash (K10D).
Jul 16, 2008

I have been having a problem getting my camera (K10D) to force flash under certain circumstances. It was my understanding that when in the P mode, if the flash setting is turned on and the flash is up, it is supposed to flash. Is this correct?

I have had a couple cases recently, where I could not get the flash to go off, even with the flash setting on. In both cases, I was shooting someting dark, with direct sunlight shining through a small opening. Last night for example, I was taking silhouette shots of a dead tree at sunset. Just for effect, I wanted to use the flash to light the tree, but it would not do it when the sun was coming through an opening between branches. If the sun was obscured, or if I turned around to shoot the night sky, the flash would go off. But if the sun was in the shot, the camera would not flash.

Does anyone know if there is something wrong with my camera? If not, how do I get it to force the flash? Like I said, I thought that in the P mode, with the flash setting on, the flash was supposed to flash, no matter what, when it is popped up.

Any help would be appreciated. Thanks.

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow