Sigma 30/1.4 on D300 with SB-800 huge front focus

Started Apr 13, 2008 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
klappa
Forum MemberPosts: 60
Like?
Sigma 30/1.4 on D300 with SB-800 huge front focus
Apr 13, 2008

Interesting thing happened to me regarding my Sigma 30/1.4 which I bought last summer. I've been using it on my Nikon D40 since then and it was quite ok, slight front-focus now and then, but otherwise great.

Last week I got a new Nikon D300, where I noticed the front focus more (fixable with AF fine tuning setup on D300, value +13 seems to make it focus right), but when I use it with the SB-800 flash, the same I used on D40 with the same glass without any problem, it suddenly focuses completely wrong, about 10-50cm before subject (aprox.) depending on the subject distance. It does look ok in the viewfinder, but the result is completely blurry. This heavy front-focus problem occurs only when the red SB-800 focus illumination is used - otherwise, when in good light (so it focuses without the flash illumination), it's ok and also, when trying in dark when I choose other than center focus point on D300 (so the flash focus illumination is not used) it also focuses ok (except with no illumination help, so it's slow and not reliable). Putting it back to center focus point, when focusing further than about 1foot, it's completely off again.

Have you ever seen such behaviour with this combination ? Could it be fixed ?

-- hide signature --
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow