10D autofocus broke on Saturday

Started Jul 8, 2007 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
ReneS
New MemberPosts: 18
Like?
10D autofocus broke on Saturday
Jul 8, 2007

Hi,

On Friday I was in Lime Rock, CT to take pictures of the American Le Mans Series. After a couple of hundred pictures the autofocus of my Canon 10D stopped working.

First I changed the lens. Same result, the camera is just "hunting". New battery, new CF-card, full reset, I even took out the CR2032 battery. Same result.

In the evening I started to investigate the problem and tried all four of my lenses. Same result. But suddenly I was hearing the bleep again but only rarely... after playing for another 30min, I discovered, that the autofocus works, when I turn the camera in a 50 degree angle up or rotate it by 180 degrees, means upside down.

So I survived the Saturday and the race by holding the camera upside down (bottom-up) and did some manual focusing where possible. It worked but after a while my arms got tired... and I got some strange looks.

Has anyone encountered such behavior before? I suppose that the build-in orientation sensor does not work properly anymore... and shaking does not help

Does it make sense to get it repaired? Shall I buy a used 10D to survive until the new once come out? I do not want to spend a lot of money for a 30D now and see in 3 month the successor on the market. I made the mistake already with the 10D.. waited six month... was impatient... bought the 10D and saw the 20D just one month later for less in stores.

Any advise is highly appreciated.

Rene

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow