Kodak 5100 printhead failure

Started May 9, 2007 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
jdytart
New MemberPosts: 6
Like?
Kodak 5100 printhead failure
May 9, 2007

I bought a Kodak 5100 several weeks ago and got it set up without difficulty. It seemed to be printing fine, but after a couple of days it suddenly stopped printing - only blank pages came out, including trying the copier.

I called tech support, who determined the printhead had failed, and sent me a new one. With the help of tech support, I got the new one installed when it came, and the printer now seems to be working fine.

Then, last night, a Kodak representative called me, and wanted me to return the old printhead so they could determine what had caused the problem. Sorry, I had already tossed it. I tried to find out if this was a common problem, but of course he wouldn't say - but, IF it should happen again, they would send me a new one, and if I would return the old one, they would send me some free ink.

This is rather worrying - did I buy this too soon before all the bugs have been worked out? Has anyone else had this problem?

The only good thing is that they have a support line just for the 5100 and 5300, which was answered instantly by a human being... but this could also mean they are having so many problems they had to set up a special line just to handle them.

Judy

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow