HELP!!! 24-105 IS trouble.

Started Sep 27, 2006 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
studiomk
Regular MemberPosts: 209
Like?
HELP!!! 24-105 IS trouble.
Sep 27, 2006

I have recently had a problem with the IS on the 24-105L IS lens. It became very noisy and seemed to blur rather than keep sharp images. I have had it for about 9 months before this fault developed. Up until then I was a very happy man. Hand holding down to a 1/20th for some mixed lighting for great sharp images.

Sent lens to Fiixation London, said IS unit faulty and replaced it. Lens comes back and I noticed straight away the noise was far louder when the IS was working than it was before. Also, and more important my mind, when I press half press the shutter to activate IS and AF the image seems to jump in the viewfinder. This is even more noticatble when the IS/AF switch off when you leave release the half pressure on the shutter for a few seconds. Now I don't remember either the noise being so loud, or more importantly the jumping of the image with the lens for the previous 9 months. I think I would remember it is that noticable.

Is the IS the same on other peoples lenses. Either 70-200 or 24-105? Do you notice a jump of the image in the viewfinder when the IS engages or switches off? I tested a lens at Jessops and the image did not seem to jump on that lens either. Fixation have had the lens back and stated it is the same as there other 'rental' lenses and they can see no problem. I am testing the lens at the moment, but don't fancy this developing into a major fault 3 months down the line when my warrenty runs out.

Also posting this on the 5D/1DS forum to aid response.

-- hide signature --
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow