Canon CCD repair Experience

Started Dec 17, 2005 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
VT
VT
Regular MemberPosts: 446
Like?
Canon CCD repair Experience
Dec 17, 2005

My A70 CCD Repair Experience

Canon issues advisory notice
http://www.dpreview.com/news/0510/05100602canon_ccdproblem.asp

CCD failures the Bigger Picture -
http://www.imaging-resource.com/NEWS/1128958202.html

I contacted Canon back in October about the CCD problem on my old Canon A70 -

after a few e-mails I established with them that my CCD problem was INTERMITTENT - so the standard "test" they outlined would not necessarily show the camera had the CCD fault.

It helped that I had actually saved a few of these faulty magenta streaky shots - and sent them a sample full photofile (with the EXIF data) - (shown here resized)

(to get larger image url - right-click on thumbnail to display properties copy the url and remove the .th from the string)

IMG_1843.JPG (0.82Mb)
Partial EXIF -
Model - Canon PowerShot A70
DateTime - 2005:03:09 23:44:55
ExposureTime - 1/8 seconds
FNumber - 2.80
Flash - Flash fired, compulsory flash mode
FlashPixVersion - 0100
ColorSpace - sRGB
ExifImageWidth - 2048
ExifImageHeight - 1536
Quality - Fine
Digital zoom - None
Contrast - Normal
Saturation - Normal
Sharpness - Normal
ISO Value - 100
Metering mode - Evaluative
Focus type - Auto
AF point selected -
Exposure mode - Tv-priority
Flash bias - 0.00 EV
Subject Distance - 44
Image Type - IMG:PowerShot A70 JPEG
Firmware Version - Firmware Version 2.00
Image Number - 4181843

That was enough to convince them to send me a shipping label and a form for Request for Evaluation.

I sent my faulty Canon A70 in on Oct/24 - and it was repaired FREE of charge and returned to me early November.

I was not in town to receive the repaired camera (although I did put on my repair form that I was going to be out of town for the period when they shipped the camera). So I didn't get the A70 back until Nov/28 - after I contacted Canon a few times and they realized that it had been returned to them by FedEx and re-shipped it to me.

The notes on the Service details was:
"Repair connector unit, cleaned and checked all functions. CXB19I65"

UNfortunately when I tested the camera - I found it would now occassionally take/store a completely blank/black shot, even though the camera would give all indication it was functioning correctly when fired - like the shutter sound and flash going off.

So... I contacted Canon by e-mail again and attached a sample of this blank/black photo - this time since it was pretty easy to reproduce I took them on the small (640x480) size at Fine.

This is the full file hosted at ImageShack - I assume one can download the full file and inspect the EXIF -

(to get full sized imagefile url - right-click on thumbnail to display properties copy the url and remove the .th from the string)

IMG_9256.JPG
partial EXIF data
Model - Canon PowerShot A70
DateTime - 2005:11:28 15:01:00
ExposureTime - 1/60 seconds
FNumber - 2.80
Flash - Flash fired, compulsory flash mode
FlashPixVersion - 0100
ColorSpace - sRGB
ExifImageWidth - 640
ExifImageHeight - 480
ISO Value - 100
Metering mode - Evaluative
Focus type - Auto
Exposure mode - Program
White Balance - Auto
Flash bias - 0.00 EV
Subject Distance - 120
Image Type - IMG:PowerShot A70 JPEG
Firmware Version - Firmware Version 2.00
Image Number - 4929256

I got a phone call from Canon and was told that they'd send out another form and shipping label and they'll replace the camera.

I duely did that attaching my correspondence about the problem - that was on Dec/1.

I just got the camera back today Dec/14 - they did NOT replace it -

Notes on Service Details:
"Replaced flash unit,repaired CCD connector, checked all functions. cxb19i40"

However my Canon A70 appears to be functioning fine - I've probably taken nearly 50 test shots, and not a single blank so far......

So, so far so good............

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow