Frustrated with Sigma EX

Started May 10, 2005 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
alex wetmore
Senior MemberPosts: 1,394
Like?
Frustrated with Sigma EX
May 10, 2005

About 6 months ago I bought a Sigma EX 70-200/2.8. It has nice optical quality but has two annoying issues:

1) The aperture ring feels awful. Not a big issue since you normally leave it on A, but an expensive lens shouldn't feel so awful.

2) It doesn't properly implement the lens mount, so it won't work with the Pentax A 2X-S teleconverter except in manual mode. That would be okay except for issue #1.

As a result I bought the 2X Sigma EX teleconverter from KEH. It arrived today. It is used, but appears to be in very good shape.

It hardly works with the Sigma EX 70-200, the lens that it is designed to work with. The "screwdriver blade" for AF between the lens and teleconverter don't line about about 5 times out of 6, meaning that the camera won't AF. When it does AF it is slow and about twice as loud as the lens by itself. The lens isn't very secure on the teleconverter mount either.

I think the teleconverter is going back and I'm tempted to eBay the lens too. It isn't worth the build quality hassles.

In the same order I got a Pentax A 70-210/4. It is light and has a much nicer build quality. If it tests at all close to the Sigma then I know which one I'm keeping.

alex

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow